Авторизация

НАСТРОЙКИ MIKROTIK PPTP

для работы с VPNKI по протоколу PPTP

Спасибо за инструкцию пользователям Rualark и Sadula!

 

1. Откройте Winbox Mikrotik.

 

2. Добавьте новый интерфейс PPTP:

"Interfaces" > "+" > PPTP Client

"Name": vpnki

"Type": PPTP Client

2

 

3.  Далее выберите вкладку "Dial Out"

"Connect to": msk.vpnki.ru

"User": <UsеrXXX> - Имя пользователя Вашего подключения

"Password": <Ваш пароль>

"Profile": default encryption

"Keepalive Timeout": 60

"Allow": mschap2, chap, mschap1, pap

3

 

4. Переходим на вкладку "IP" > "Route List" и проверяем в таблице наличие маршрута 172.16.0.0/16

Если он отсутствует, то добавляем вручную

6

 

5. Если вы объединяете две сети с Микротиками на обоих сторонах, то для доступа к другой сети, подключенной через другой туннель, необходимо на сайте в разделе сайта «Мои настройки / Настройки туннелей» выбрать каждый из двух туннелей и добавить сеть, находящуюся за этим туннелем, а затем в Mikrotik Winbox на вкладке "IP" > "Routes" добавить маршрут к удаленной сети через адрес 172.16.0.1.

Это нужно делать на каждом из устройств Mikrotik. Например, если сеть 192.168.9.0 подключена к локальному устройству Mikrotik, а сеть 192.168.8.0 находится за удаленным устройством Mikrotik, то на локальном устройстве Mikrotik необходимо добавить маршрут к сети 192.168.8.0:

 mikrotok pptp vpnki

Дополнение про L2TP

Команды, которые нужно добавить в консольном режиме настройки

/ip route
add distance=1 dst-address=172.16.0.0/16 gateway=172.16.0.1
add distance=1 dst-address=192.168.8.0/24 gateway=172.16.0.1
 
/interface l2tp-client
add connect-to=msk.vpnki.ru disabled=no ipsec-secret=vpnki name=vpnki password=xxx use-ipsec=yes user=xxx

 

 

PS: В целях борьбы с зависшими сессиями мы принудительно отключаем пользовательские туннели с протоколами PPTP, L2TP, L2TP/IPsec через 24 часа после установления соединения. При правильной настройке соединения должны автоматически переустановиться.

 

 

Наша система будет работать с многими типами домашних и офисных маршрутизаторов. Более подробно смотрите в разделе по настройке оборудования, а начать настройку лучше с этого примера.

ДОПОЛНИТЕЛЬНО ПО ТЕМЕ

  • Про VPN и протоколы можно почитать здесь