Авторизация

Topic-icon Проблема с подключением

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
19 июль 2019 20:39 - 20 июль 2019 07:50 #4313 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
Раньше МД стоял на PC Win7 на даче, с писюка поднималось моментом OpenVpn Переехал на "малинку", прицепил в ту же сетку,, VPN не поднимает, с домашней сетки эта малинка поднимает махом VPN
Последнее редактирование: 20 июль 2019 07:50 от Alex13-45.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
22 июль 2019 20:58 #4319 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
почему Raspberry в одной сети поднимает OpenVPN, а в другой нет, хотя компы с Win7 в обеих этих сетках отлично поднимают OpenVPN ?
(сетка через 3G модем и роутер, тут и не хочет поднимать малинка)
Пишет: Could not determine IPv4/IPv6 protocol (Не удалось определить протокол IPv4 / IPv6)
Но в другой то сети такого нет и все подключается.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
22 июль 2019 21:18 #4320 от admin
admin ответил в теме Проблема с подключением
Судя по интернету, это не ошибка, а предупреждение.
Пришлите полный лог попытки соединения.
А заодно еще вывод команд:
ip route
ifconfig

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
23 июль 2019 06:42 #4321 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
Вечером, после работы скину. Вчера вводил ifconfig

цитата: "в выводе команды вы должны увидеть интерфейс с имиеме tun0", так вот tun0 там не было

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
23 июль 2019 18:57 - 23 июль 2019 19:02 #4323 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
ip route
default via 192.168.100.7 dev eth0 src 192.168.100.100 metric 202
192.168.100.0/24 dev eth0 proto kernel scope link src 192.168.100.100 metric 202

ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.100.100 netmask 255.255.255.0 broadcast 192.168.100.255
ether b8:27:eb:c8:f1:ed txqueuelen 1000 (Ethernet)
RX packets 3977 bytes 219312 (214.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2882 bytes 1772098 (1.6 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
loop txqueuelen 1000 (Local Loopback)
RX packets 13075 bytes 1618860 (1.5 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 13075 bytes 1618860 (1.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:9d:a4:b8 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B )
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B )
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Похоже что не просто OpenVPN не поднимается, а вообще нет доступа к интернету, потому что в "мажоре" данные погоды не могут обновиться.
Последнее редактирование: 23 июль 2019 19:02 от Alex13-45.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
23 июль 2019 20:56 #4325 от admin
admin ответил в теме Проблема с подключением
Судя по выводу команд - все верно. Но вот насчет доступности Интернет с распберри я ничего сказать не могу.
Выполните с нее ping ya.ru

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
23 июль 2019 20:57 - 24 июль 2019 00:41 #4326 от admin
admin ответил в теме Проблема с подключением
А когда ее привезли из другого места, вы на ней адрес-то меняли?

если все заработало - нажмите на баннеры!
Последнее редактирование: 24 июль 2019 00:41 от admin.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
24 июль 2019 05:12 #4327 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
При выводе отчета по команде ifconfig, нет строки tun0. Адрес не менял т.к. привез вместе с модемом и роутером. Если поключить к домашней сетке, то все работает.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
24 июль 2019 10:44 #4333 от admin
admin ответил в теме Проблема с подключением
tun0 появится когда стартует openvpn, пока его нет, то и интерфейса нет.
Скажите, так доступ в Интернет с распберри есть? Пинг проходит?

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
24 июль 2019 10:48 #4334 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
ping ya.ru даже в "рабочей сетке" не проходит

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
24 июль 2019 10:52 #4336 от admin
admin ответил в теме Проблема с подключением
Как так? Ну хорошо, а ping 8.8.8.8 ?

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
24 июль 2019 11:01 #4337 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
Вот сейчас подключен с "нормальной сетки" туннель поднялся, пинг на 172.16.0.1 проходит, а на 8.8.8.8 нет

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
24 июль 2019 12:01 #4343 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
Сейчас админы "потыкались" в моей связке (Raspberry+Tp-Link TL-MR3020+3G/4G модем) и сказали что какая-то личная неприязнь у них, т.к.даже не пингуется DHCP Tp-Link-а. С любого другого компа или ноута пинги идут, с Raspbery не хотят.
В чем косяк, не понятно.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
24 июль 2019 12:23 #4346 от admin
admin ответил в теме Проблема с подключением
Я правильно понимаю, что у ТПлинка внутренний адрес 192.168.100.7 ? Он пингутся с напрямую подключенной распберри?

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Alex13-45
  • Alex13-45 аватар Автор темы
  • Не в сети
  • Продвинутый повелитель пингов
  • Продвинутый повелитель пингов
Больше
24 июль 2019 12:31 - 24 июль 2019 13:12 #4347 от Alex13-45
Alex13-45 ответил в теме Проблема с подключением
Да, адрес 192.168.100.7 На прямую с распберри не пингуется, с любого другого ПК пинг идет.
Последнее редактирование: 24 июль 2019 13:12 от Alex13-45.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.