Авторизация

Topic-icon Не могу соединить два туннеля!!!

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 20:12 #1268 от Nik_kola65
Nik_kola65 создал эту тему: Не могу соединить два туннеля!!!
Здравствуйте. Вчера настроил туннели между андроидом и роутером openwrt по pptp. Все работало. А сегодня не пингуется 172.16.0.251 с андроида. С сайта и с роутера все ок. 172.16.0.1 с андроида пингуется. В чем может быть причина? Форум читал...

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
08 дек 2017 20:47 #1273 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Где-то нет маршрута. Скорее всего на андроиде. Должен быть 172.16.0.0/16 в настройках соединения

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 21:08 #1274 от Nik_kola65
Nik_kola65 ответил в теме Не могу соединить два туннеля!!!
в настройках соединения все прописано

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
08 дек 2017 21:10 #1275 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Хорошо, давайте тогда более детально - имена туннелей, IP адреса и типы устройств

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 21:17 #1277 от Nik_kola65
Nik_kola65 ответил в теме Не могу соединить два туннеля!!!
HomeSmat - адрес 172.16.0.251 роутер MR3020 с openwrt
Android - адрес 172.16.0.252 телефон Xiaomi Redmu4 pro

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
08 дек 2017 21:21 #1278 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Хорошо, а на openwrt есть такой же маршрут, который смотрит на VPN интерфейс?

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 21:28 #1279 от Nik_kola65
Nik_kola65 ответил в теме Не могу соединить два туннеля!!!
В openwrt прописаны. Вчера все работало.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
08 дек 2017 21:36 #1280 от admin
admin ответил в теме Не могу соединить два туннеля!!!
А что нибудь меняли на сайте или в своих устройствах вчера или сегодня утром?

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 21:42 #1281 от Nik_kola65
Nik_kola65 ответил в теме Не могу соединить два туннеля!!!
Да вроде ничего не менял.
А в интерфейсе VPNKI адрес правильный?

Время работы: 0h 3m 28s
RX: 52.00 B (4 Пакетов.)
TX: 72.00 B (5 Пакетов.)
IPv4: 172.16.0.251/32

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 21:51 #1282 от Nik_kola65
Nik_kola65 ответил в теме Не могу соединить два туннеля!!!
Все заработало. Спасибо!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
08 дек 2017 21:54 #1283 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Да, правильный,
У меня есть ощущение, что openwrt не отвечает на пинги из сети 172.16.0.0/16

Это не точно, но вот

Это успешный пинг если адрес интерфейса источника - 172.16.0.1
21:49:31.873812 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 32695, seq 4, length 64
21:49:31.953282 IP 172.16.0.251 > 172.16.0.1: ICMP echo reply, id 32695, seq 4, length 64



А это неуспешный пинг если адрес был другой (его тут не видно)
21:51:12.262199 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 5522, seq 6, length 64
21:51:13.262538 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 5522, seq 7, length 64
21:51:14.270205 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 5522, seq 8, length 64
21:51:15.278386 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 5522, seq 9, length 64
21:51:16.286189 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 5522, seq 10, length 64
21:51:17.294204 IP 172.16.0.1 > 172.16.0.251: ICMP echo request, id 5522, seq 11, length 64

Ответов от опенврт нет. Есть ли возможность перезагрузить его?

если все заработало - нажмите на баннеры!
Спасибо сказали: Nik_kola65

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Nik_kola65
  • Nik_kola65 аватар Автор темы
  • Не в сети
  • Пользователь заблокирован
  • Пользователь заблокирован
Больше
08 дек 2017 22:00 #1284 от Nik_kola65
Nik_kola65 ответил в теме Не могу соединить два туннеля!!!
Oprnwrt не перезагружал. Все чудесным образом заработало.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
08 дек 2017 23:07 #1285 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Хорошо, но странно это.
Надо понаблюдать.

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 18:24 #1309 от accordeon
accordeon ответил в теме Не могу соединить два туннеля!!!

admin пишет: Хорошо, а на openwrt есть такой же маршрут, который смотрит на VPN интерфейс?

А как в опенврт его прописать?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 18:41 #1310 от admin
admin ответил в теме Не могу соединить два туннеля!!!
habrahabr.ru/post/128451/
пример в разделе Настройка сетевых интерфейсов

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 19:02 - 10 дек 2017 20:39 #1311 от accordeon
accordeon ответил в теме Не могу соединить два туннеля!!!
Ууу жесть.. а для люси нет версии? )))
какой файрвол должен быть у интерфейса VPNKI wan или lan?
А порты пробрасывать нужно?
И для вебморды люси тоже?
Проверьте меня, ни в какую не коннектятся хотя все в Инструментах пингуется:
172.16.12.10 via 172.16.0.1 dev ppp48 scope link
172.16.12.19 via 172.16.0.1 dev ppp121 scope link
192.168.1.0/24 via 172.16.12.10 dev ppp48
192.168.2.0/24 via 172.16.12.19 dev ppp121

user3518 user3527

Это с машины 192.168.1.1
Обмен пакетами с 192.168.2.1 по с 32 байтами данных:
Ответ от 192.168.2.1: число байт=32 время=18мс TTL=61
Ответ от 192.168.2.1: число байт=32 время=19мс TTL=61
Ответ от 192.168.2.1: число байт=32 время=18мс TTL=61
Ответ от 192.168.2.1: число байт=32 время=18мс TTL=61

Статистика Ping для 192.168.2.1:
Пакетов: отправлено = 4, получено = 4, потеряно = 0
(0% потерь)
Последнее редактирование: 10 дек 2017 20:39 от accordeon.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 21:38 #1312 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Я так понимаю, что со страницы Инструменты вы пингуете 192.168.1.1 и 192.168.2.1, так?
Тогда что не работает?
Порты пробрасывать не нужно
Насчет фаервола - признаюcь, я в глаза никогда OpenWRT не видел :)

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 21:41 #1313 от accordeon
accordeon ответил в теме Не могу соединить два туннеля!!!
Да со страницы, все пингуется, а вот друг друга не видят
Кто бы уточнил как route прописать

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 21:42 #1314 от admin
admin ответил в теме Не могу соединить два туннеля!!!
1. на 192.168.1.1 порт 80
ответ
Redirecting to /home.html
то есть порт слушает и все ок

2. на 192.168.2.1 порт 80
ответ Failed to connect to 192.168.2.1 port 80: Connection refused
То есть фаервол где-то по пути к 192.168.2.1 или сам 192.168.2.1 заблокировал трафик. Ищите там в настройках фаервола.

Эти команды вы можете тоже ввести на странице Инструменты

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
10 дек 2017 21:45 #1315 от admin
admin ответил в теме Не могу соединить два туннеля!!!
если не видят друг друга то дело в маршрутах,
1. должен быть 172.16.0.0/16 с шлюзом 172.16.0.1 с обоих сторон
2. на стороне с адресом 192.168.1.1 должен быть маршрут к 192.168.2.0/24 с шлюзом 172.16.12.19
3. на стороне с адресом 192.168.2.1 должен быть маршрут к 192.168.1.0/24 с шлюзом 172.16.12.10
увы, по форме записи я не помогу - не знаю

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 дек 2017 13:00 #1317 от Victvv
Victvv ответил в теме Не могу соединить два туннеля!!!
Вчера все работало.
Сегодня перезапустил туннель на роутере и все легло
Конфигурация
Home (роутер) - 172.16.12.55
Work (openvpn) - 172.16.12.57
oneplus (android) - 172.16.12.63
На сайте все туннели подняты, статус с зеленым кругом.
Work и oneplus пингуют друг друга, но не пингуют Home.
Home пингует только себя и 172.16.0.1
на Home только один маршрут 172.16.0.1/32 0.0.0.0 PPTP0
и отсутствует 172.16.0.0/16 0.0.0.0 PPTP0
Что нужно докрутить?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 дек 2017 13:31 #1318 от Victvv
Victvv ответил в теме Не могу соединить два туннеля!!!
После очередного передергивания туннеля все заработало

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 дек 2017 14:54 - 11 дек 2017 14:56 #1323 от accordeon
accordeon ответил в теме Не могу соединить два туннеля!!!
Самое интересное, что с третьего устройства (андроид) видит и сеть 192.168.1.0 и 192.168.2.0 !
Т.е. в роутере неправильно выставлен маршрут... но как?? может файрволл крутить нужно???
Вложения:
Последнее редактирование: 11 дек 2017 14:56 от accordeon.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 дек 2017 20:48 - 11 дек 2017 20:54 #1333 от accordeon
accordeon ответил в теме Не могу соединить два туннеля!!!
Решение нашел: luci это зло!
Добавил в настройках /etc/config/network

config interface 'VPNKI'
option proto 'pptp'
option server 'vpnki.ru'
option username 'userХХХХ'
option password 'ХХХХХХХХ'
option delegate '0'
option defaultroute '0'

config route
option interface 'VPNKI'
option target '192.168.2.0'
option netmask '255.255.255.0'
option gateway '172.16.0.1'


и /etc/config/firewall

config zone
option name 'VPN'
option input 'ACCEPT'
option output 'ACCEPT'
option network 'vpn'
option forward 'ACCEPT'
option masq '1'
option network 'vpn VPNKI'

config forwarding
option dest 'lan'
option src 'VPN'
config forwarding
option dest 'VPN'
option src 'lan'

Все работает!!!
Последнее редактирование: 11 дек 2017 20:54 от accordeon.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
11 дек 2017 21:36 #1334 от admin
admin ответил в теме Не могу соединить два туннеля!!!
Хорошо, поздравляю с победой :)

если все заработало - нажмите на баннеры!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.